Technorati Rank WordPress Plugin versjon 2 utgitt!

Varmt på hælene til den første Technorati Rank Plugin, jeg har redesignet utdataene for å gjøre det CSS drevet (nedenfor er et skjermbilde, du kan samhandle med det i sidefeltet til nettstedet mitt):

Technorati Rank WordPress Plugin versjon 2

Denne var litt mer utfordrende å produsere, men produksjonen er mye bedre. Først brukte jeg det jeg har lært om Bittbox for å lage hver av utgangsknappene på bildet i Illustrator.

Det neste trinnet var å bruke stiler for å faktisk bygge noen av en bildekart bortsett fra at det faktisk er det ikke noe kart! Det er ganske kult, faktisk. Du kan angi den samlede div-bakgrunnen og deretter opprette hver av "hotspots" ved hjelp av absolutt posisjonering og CSS. Vis utdata CSS.

Jeg la også til en lenke til Technoratis nye WTF siden og nettstedets RSS-adresse. Jeg håper du liker det! Jeg synes det er en enorm forbedring fra den første versjonen! Det er en i lenke nederst til høyre som også promoterer plugin.

Nåværende Technorati Rank WordPress Plugin versjon 2.0.4

23 Kommentarer

  1. 1
    • 2

      Det er sikkert! Jeg hadde lett etter Illustrator-assistanse i ganske lang tid. Jeg bruker det ikke nok til å være fantastisk på det, så et nettsted som Bittbox sparer meg MYE tid!

  2. 3

    Jeg prøvde å installere det nyeste og beste ved å følge instruksjonene dine til "bokstaven" 🙂

    men jeg fikk følgende feil

    Alvorlig feil: Kan ikke starte øyeblikkelig klasse: simplexmlelement i /home/winex4/public_html/wp-content/plugins/technorati-rank/technorati-rank.php på linje 64

    noen forslag?

    • 4
      • 5

        som vil lære meg å sjekke først .. tilsynelatende kjører Lunarpages 4.4.4 av PHP

        Antar at jeg må sjekke ut den andre versjonen eller henge tøff og se om de oppgraderer til 5.0

        • 6

          Jeg håper de gjør det! Men jeg håper også verten din oppgraderer. PHP5 gir virkelig mye bedre ytelsesforbedringer, samt noen bedre verktøy for å konsumere APIer. Jeg bruker Jumpline, du vil se en lenke i sponsorlisten min på hjemmesiden min. Jeg tror også at Dotster har god VDS-hosting med det siste og beste.

      • 7

        Doug,
        Jeg har det samme problemet
        Jeg ringte verten min og de sa at serveren min har PHP 4 og PHP 5, men hvis jeg vil kjøre en fil ved hjelp av PHP 5, må skriptet ha filtypen .php5.

        Så ... Jeg endret filtypene, og den forsvinner fra plugins i wordpress.

        Noen ideer?

  3. 10

    Fantastisk plugin, utmerket styling! Takk Doug, og flott arbeid. Jeg visste ikke en gang om den første, men dette går i sidepanelet.

    Det er virkelig givende å se at Illustrator-tipsene mine hjalp deg med å lage knappene dine !!!!!

    takk igjen,

    ~ BittBox

    • 11

      Takk, BittBox! Jeg tror jeg har et godt øye for stil, men jeg ser aldri ut til å få det riktig mesteparten av tiden. Å kunne laste ned prøvene dine og dissekere dem er det som gjør forskjellen. Jeg er i stand til å virkelig utføre disse ideene nå. 🙂

      Jeg leker med noen tanker om bloggens overskrift og bakgrunn neste.

  4. 12

    Vel, Doug, det ser ut til at versjon 2-plugin hater meg. Jeg får feilmeldinger:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    Til tross for feilmeldingene viser den også Technorati-rangeringen min (~ 26.5k: D). Jeg er ikke kunnskapsrik nok om PHP til å vite hvorfor det gråter over den ene filen.
    Interessant nok bruker vi SuPHP på serveren vår, så alt kjører som oss (så chmod-krav krever ikke lenger verdensskrivbare filer, og php-skript vil ikke utføres hvis for eksempel chmod'ed er for høyt).

    All php for dette underdomenet kjører som php5.

    Noen ideer?

    • 13

      Har du en wp-content / cache-katalog Xial? Jeg trodde det ville være en god idé å bruke samme cache-katalog som WP-Cache. I ettertid var det kanskje ikke en god idé! Den linjen er definitivt å skrive til hurtigbufferfilen.

      • 14

        Det gjør jeg absolutt, Doug. Jeg har kjørt WP-Cache en god stund. 🙂

        Jeg var også litt nysgjerrig på hvorfor det ville klage på dette, siden jeg har den nødvendige katalogen, men jeg antar at det er noe annet helt.

      • 15

        Interessant litt informasjon å legge til:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        Det returnerer fortsatt feilene.

    • 16

      Vil bare ringe inn med å ha den samme feilen. Nettstedet kjører php5, og knappen vises.
      Jeg prøvde å kommentere linjene 121-123, og pluggen fungerer bra. Kan jeg sette den i live, eller vil mangelen på disse linjene forårsake problemer på lengre sikt?

  5. 17

    Jeg får de samme feilene som ovenfor, jeg trodde også det var min cache-dir, men jeg har en og sørget også for at skriverett var riktig.
    I sidefeltet vil det vise pluginet (med rang), men med feilene over det.

    • 18

      Hei Richard,

      Kan du sjekke om du har PHP versjon 5+ og at CURL er aktivert? Du kan gjøre dette ved å bygge en side på nettstedet ditt med <?php phpinfo(); ?> på en side. Åpne deretter siden. Toppen av siden vil ha din versjon av PHP, og du kan søke etter CURL for å sikre at den er aktivert.

      Takk!
      Doug

      • 19

        Vel, Doug, jeg dobbeltsjekket PHP-versjonen min.
        Jeg kjører PHP5, og cURL er samlet i (en av mine vanlige tre forespørsler til verten min, om at ting skal kompileres til PHP).

        Alt annet fungerer bra, men jeg er ikke helt sikker på hvorfor dette pluginet kveles, med mindre det er versjonen av cURL som er samlet inn til PHP (vi er på 7.15.4, og den siste ser ut til å være 7.16.1). Imidlertid vil jeg ikke plage verten min for å kompilere php5 igjen bare for det, hvis jeg kan hjelpe det. <: 3

        • 20

          Jeg skal se nærmere på denne helgen. Den kjører uten problemer på noen få nettsteder - så det er en av tre ting: 3. Cache, 1. cURL eller 2. PHP-versjon.

          Jeg kan bruke eldre PHP 4-funksjonalitet til å hente og analysere XML, men det kan redusere det ganske mye - jeg skal teste denne helgen. Jeg setter pris på alle innspillene. "Houston vi har et problem!".

  6. 21

    Bare en merknad: Technorati har lansert en Myndighet Plugin.

    Også - for alle de som har problemer med dette pluginet, vil jeg virkelig oppfordre deg til å flytte til en ny vert :). Jeg har en 12 måneders gratis spesial med verten min nederst på Om side.

  7. 22
  8. 23

    Jeg har mottatt ganske mange forespørsler om at det har skjedd eller lest feil fra hurtigbufferfilen. Jeg identifiserte faktisk et problem der jeg presset og dro cache-filen til rotkatalogen. Jeg har endret versjon 2.0.4 slik at den skriver til en cache-underkatalog i plugin-katalogen.

    Gi meg beskjed om hvordan det går! (Trenger fortsatt SimpleXML og cURL!)

Hva tror du?

Dette nettstedet bruker Akismet for å redusere spam. Lær hvordan kommentaren din behandles.